Excel: 3 Beispiele für den Einsatz der bedingten Formatierung

15. Juli 2015

Bedingte Formatierung in Excel 2007, 2010 und 2013

Die bedingte Formatierung ist ein kleiner Geniestreich in Excel. Denn sie sorgt für Übersichtlichkeit und eine bessere Lesbarkeit in Ihren Excel Tabellen und Listen. Dank dieser Excel-Funktion können Sie bequem Ihre Zahlen, Texte und/oder Formelergebnisse daraufhin überprüfen, ob eine oder mehrere Kriterien zutreffen. Das Besondere ist: Bedingte Formatierungen

  • bleiben solange bestehen, bis Sie diese löschen.
  • haben stets Vorrang vor anderen Formatzuweisungen, die Sie in der Tabelle oder Liste vornehmen.
  • ermöglichen es Ihnen, die Darstellung der Schrift, die Füllfarbe der Zellen, sowie die Rahmenlinien zu verändern.

 Excel - Bedingte Formatierung auf www.business-netz.com

Excel: Bedingte Formatierung im Einsatz – 3 Beispiele

Beispiel 1: Farbliche Leselinien zur besseren Orientierung einfügen

Erleichtern Sie sich das Lesen langer Tabellenreihen. Färben Sie jede zweite Zeile farblich ein.

  • Markieren Sie den Zellbereich, den Sie in Ihrer Excel Tabelle durch die bedingte Formatierung mit Farbe ausfüllen lassen möchten.
  • Öffnen Sie die Registerkarte Start.
  • Klicken Sie in der fünften Gruppe Formatvorlagen auf die Schaltfläche Bedingte Formatierung.
  • Im Drop-down-Menü klicken Sie auf den Befehl Neue Regel.
  • Es öffnet sich das Fenster Neue Formatierungsregel.
  • Wählen Sie im Feld Regeltyp auswählen den Befehl Formel zur Ermittlung der zu formatierenden Zellen verwenden.
  • Es öffnet sich ein neues Fenster, das auch Neue Formatierungsregel heißt. Tragen Sie in das Feld Regelbeschreibung bearbeiten folgende Formel ein: =REST(ZEILE();2)=1.
  • Klicken Sie anschließend auf die Schaltfläche Formatieren.
  • Im Dialogfenster Zellen formatieren können Sie nun die Farbe auswählen, indem Sie einfach auf eine der angezeigten Farben klicken. Wollen Sie weitere Farbeffekte einsetzen, klicken Sie auf die Schaltfläche Fülleffekte und/oder Weitere Farben.
  • Bestätigen Sie Ihre Auswahl mit einem Klick auf OK.
  • Schließen Sie auch das Dialogfenster Neue Formatierungsregel mit einem Klick auf OK.
  • Jede zweite Zeile in Ihrer Excel Tabelle wird nun farblich durch eine Leselinie hervorgehoben.


Beispiel 2: Gruppierungslinien einsetzen

Vereinen Sie zusammengehörige Datensätze durch Trennlinien.

  • Wiederholen Sie die ersten Schritte des ersten Beispiels – bis Sie zu dem Befehl Formel zur Ermittlung der zu formatierenden Zellen verwenden.
  • Notieren Sie in das Feld Regelbeschreibung die Funktion: =WENN($B6<>$B5;1;0). Dadurch geben Sie Excel den Befehl den Wechsel der Artikelgruppen in Spalte B abzufragen.
  • Klicken Sie wie im ersten Beispiel auf die Schaltfläche Formatieren.
  • Öffnen Sie im Dialogfenster Zellen formatieren die Registerkarte Rahmen.
  • Wählen Sie dort die untere Zellbegrenzung aus, indem Sie
    • im Feld Art die gewünschte Linienstruktur anklicken.
    • im Feld Rahmen festlegen, dass die Linie als untere Zellbegrenzung angezeigt werden soll (dies ist die dritte Schaltfläche von links oben).
    • Schließen Sie beide Dialogfenster, indem Sie auf OK klicken.

 

Beispiel 3: Hervorhebung des ersten Eintrages

Lassen Sie sich in alphabetisch angeordneten Tabellen den ersten Eintrag der neuen Buchstabengruppe anzeigen – also beispielsweise den ersten Eintrag des Buchstabes A, B oder C usw. – indem Sie diesen farblich hervorheben.

  • Wiederholen Sie die ersten Schritte bis Sie den Befehl Formel zur Ermittlung der zu formatierenden Zellen verwenden aktiviert haben.
  • Geben Sie in das Feld Regelbeschreibung die Funktion: =$B4<>““ ein. 
  • Klicken Sie auf die Schaltfläche Formatierung.
  • Öffnen Sie die Registerkarte Schrift. Wählen Sie dort im Feld Schriftschnitt die Einstellung Fett aus und im Feld Farbe Ihre gewünschte Farbe – beispielsweise grün.
  • Schließen Sie beide Dialogfenster mit einem Klick auf OK.
  • Noch konnte Excel Ihre bedingte Formatierung nicht umsetzen.
  • Sie müssen erst zwei Formeln verfassen.
    1. Erfassen Sie in der Zelle neben den alphabetischen Daten eine Formel. Wenn die Daten in Zelle A4 stehen, setzen Sie Ihren Cursor in die Zelle B4. Die Formel, die Sie in die Zelle B4 eintragen, lautet =GROSS(LINKS(A4;1)). Mit dieser Formel erteilen Sie Excel den Befehl den ersten Buchstaben aus der Zelle A4 auszuschneiden und in B4 zu kopieren – dies wäre beispielsweise ein A.
    2. In Zelle B5 notieren Sie folgende Formel:
      =WENN(LINKS(A5;1)<>LINKS(A4;1);GROSS(LINKS(A5;1));""). Dadurch erhält Excel den Befehl bei jedem Buchstabenwechsel in den weiteren Zellen der Spalte B den ersten Buchstaben anzuzeigen und gleichzeitig links den ersten Namen dieser Buchstabengruppe farblich hervorzuheben.
  • Kopieren Sie die letzte Formel bis zum Ende Ihrer Tabelle. Sofort wird Excel die bedingte Formatierung vornehmen – und den ersten Eintrag farblich darstellen. 
Lernen Sie jetzt eine der wichtigen Excel Funktionen kennen: Das Kopieren von Excel Formeln in eine andere Zelle. So können Sie Zeit sparen und Ihre Effizienz steigern. mehr
Mit der Excel Datumsfunktion als Excel Funktion können Sie in Ihrer Excel Tabelle mühelos das aktuelle Datum anzeigen lassen oder sogar den Wochentag eines zurückliegenden Datums bestimmen. mehr
Excel Kommentare sind die integrierten Notizzettel für jedes Excel Tabellenblatt in der Excel Tabelle. Erstellen Sie in wenigen Schritten Ihre eigenen Excel Kommentare. mehr
Sie wollen eine bestimmte Aufgabe in Excel erledigen, wissen jedoch nicht, welche Excel-Funktion Sie dafür nutzen müssen. Aktivieren Sie den Funktions-Assistenten. mehr
Ihre Excel Formeln zu schützen gelingt nur, indem Sie einzelne Zellen in Excel schützen. Mit wenigen Klicks haben Sie Ihren Zellschutz in Excel aktiviert. mehr